Аналоги номенклатуры для УТ 11, КА 2, ERP [Расширение]

Публикация № 994254

Обработки - Обработка справочников

аналоги номенклатура

8
Удобное отображение аналогов прямо в списке номенклатуры. Легкое добавление и удаление аналогов к номенклатуре. Доработка в виде расширения, изменение конфигурации не требуется.

У Вас есть товары с аналогичными свойствами? Предлагаете клиентам замену?

Воспользуйтесь удобной формой аналогов для номенклатуры.
Больше не нужно открывать отдельные окна и переключатели для аналогов - они отображаются прямо в списке номенклатуры!

Отображение аналогов номенклатуры происходит прямо в списке.

Выбрали номенклатуру и сразу видим все ее аналоги, не нужно никаких дополнительных действий.
При выборе аналога переходим в списке к нему.

 

Место на мониторе часто не хватает, поэтому для аналогов предусмотрена специальная сворачиваемая группа.
Но чтобы ничего не пропустить есть информационная надпись про количество аналогов.

Если аналогов нет, то и группу открывать не обязательно.

 

В карточке номенклатуры для аналогов предназначена отдельная закладка в форме элемента.

Здесь же можно легко добавить или удалить аналоги номенклатуры.

 

При записи аналога, существующий элемент становится аналогом для выбранной номенклатуры.


Пример:

Есть 3 номенклатуры:

Печенька, Конфетка и Шоколадка.

1. Записываем для Конфетки аналог Печеньку.
- Теперь и у Печеньки есть аналог в виде Конфетки.
2. Дописываем к Конфетке еще один аналог Шоколадку.
- Теперь и у Печеньки и у Шоколадки будут записаны аналоги.
3. Все три номенклатуры являются аналогами друг друга.

 
Для этой возможности расширение должно быть подключено со снятым флагом Безопасный режим.

 

Хотите оформлять документы сразу из формы списка? Для этого есть отдельное расширение - Номенклатура и корзина

Аналоги работают с этим расширением еще круче!

- У аналогов видны остатки на складах

- Видны цены аналогов

- Аналог можно добавить в корзину и оформить документ

 Расширение Номенклатура и корзина приобретается отдельно!

 

Все очень просто!

1. НСИ и Администрирование

2. Администрирование - Печатные формы, отчеты и обработки

3. Расширения

4. Добавить из файла

5. Выбрать файл расширения на диске

6. Снять флаг "Безопасный режим" (для возможности удобной записи аналогов)

7. Перезапустить

8. Готово!

 

1. Номенклатура (Расширенная форма списка) и Корзина для УТ11, ERP и КА2 - Топ платных разработок для УТ11

2. Расширенный подбор товаров для УТ11, ERP и КА2

3. Структура подчиненности. Кнопки проведения и управление пометкой удаления

4. Новые роли. Кладовщик, кассир и менеджер по закупкам для БП3

5. Бухгалтерия на прокачку

 

1. Изменение конфигурации не требуется

2. Подходит для УТ11.4, КА2.4 и ERP2.4 и более новых версий

3. Протестировано на УТ11.4.6.230, КА2.4.7.109 и ERP2.4.7.107

4. Код расширения открыт

5. Позже расширение станет платным!

8

Скачать файлы

Наименование Файл Версия Размер
Аналоги номенклатуры для УТ11, КА2, ERP [Расширение]:
.cfe 171,35Kb
18.03.19
11
.cfe 1.7 171,35Kb 11 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. SergeyMordvin 385 19.03.19 16:54 Сейчас в теме
НУ наконец-то! Давно хотел сам подобное сделать, руки не доходили. Круто очень выглят
2. user1180228 20.03.19 09:51 Сейчас в теме
Как то столкнулся с функциональностью в телефоне, когда контакты из разных источников можно объединить в один контакт - например контакт из телефонной книги, контакт из FaceBook, контакт из Одноклассники и т.д. Как вы думаете такое возможно проделать с номенклатурой в 1с, когда есть очень много задвоенных записей, которые хотелось бы объединить и работать уже с одной единой объеденной номенклатурой.
5. mrXoxot 2091 20.03.19 14:47 Сейчас в теме
(2) Добрый день.
Есть специальные обработки по поиску и замены дублей.
Возможно, стоит посмотреть в эту сторону.
3. user597811_loki111 20.03.19 11:19 Сейчас в теме
Здравствуйте можно ли сделать подобное для розница 2.2.9?
6. mrXoxot 2091 20.03.19 14:48 Сейчас в теме
(3) Добрый день.
Можно, но это будет позже.
7. prider 19.06.19 04:37 Сейчас в теме
Добрый день!

Попытался интегрировать Вашу разработку. При попытке добавить товар (из поля Аналог) в корзину получаю вот такую ошибку (см.прикрепленный файл)
И еще момент, требующий доработки функционала(см.прикрепленный файл):
1. При подборе товара хотелось бы по умолчанию добавить поле "Номенклатура.Наименование", чтобы можно было быстрой найти необходимую номенклатуру по наименованию.
2. В поле "Подобранные товары" нет возможности удалить лишние товары, которые были подобраны на этапе 1.
Спасибо за Ваш труд и интересные разработки!
Прикрепленные файлы:
8. mrXoxot 2091 19.06.19 16:16 Сейчас в теме
(7) Добрый день, спасибо за обратную связь.
Видимо, ошибка про "ДобавитьВКорзину" связана с тем, что у Вас старая версия расширения "Номенклатура и корзина".
Можете в расширении "Номенклатура и корзина" добавить второй параметр в процедуру ДобавитьВкорзину.

Подбор используется типовой, поэтому его поведение не менял. Записал себе пожелание по развитию подбора.

И еще раз большое спасибо за обратную связь.
9. prider 27.06.19 05:39 Сейчас в теме
(8) Добрый день.
В вашем расширении выловил ошибку,а именно, когда создаешь новую Номенклатурную группу, то появляется ошибка.
В Модуле объекта требуется сделать проверку на создание новой группы.
Проблему решил следующим образом:
1.
Процедура Аналоги_ПриЗаписи(Отказ)

Если Не ЭтотОбъект.ЭтоГруппа Тогда //Проверка на создание группы
Если Отказ Тогда
Возврат;
КонецЕсли;
.....
КонецЕсли;
КонецПроцедуры
2.
Процедура Аналоги_ПередЗаписью(Отказ)

Если Не ЭтотОбъект.ЭтоГруппа Тогда //Проверка на создание группы 27.06.2019
Если ЭтоНовый() Тогда
АналогиДоЗаписи = Новый Массив;
Иначе
АналогиДоЗаписи = МассивАналоговОбъекта(Ссылка);
КонецЕсли;

ДополнительныеСвойства.Вставить("АналогиДоЗаписи", АналогиДоЗаписи);

Аналоги_ЕстьАналоги = (АналогиНоменклатуры.Количество() > 0);
КонецЕсли;

КонецПроцедуры
Оставьте свое сообщение